ESP8266: ZgatewayPilight doesn't publish anything when ZgatewayRF enabled

I’ve just received some Digoo R8S sensors that are supported by OMG and tried them out.
I downloaded, compiled and uploaded the master code to my Wemos D1 mini with only ZgatewayPilight enabled and it does work:

17:36:39: (0) home/OMG_2nd_floor/PilighttoMQTT {“message”:"{“id”:51,“temperature”:19.80,“humidity”:51.00,“battery”:1,“channel”:1}",“protocol”:“tfa”,“length”:“51”,“repeats”:2,“status”:2}

17:36:39: (0) home/OMG_2nd_floor/PilighttoMQTT {“message”:"{“id”:147.0,“temperature”:1.2,“humidity”:49.0,“battery”:0.0}",“protocol”:“teknihall”,“length”:“147”,“repeats”:2,“status”:2}

17:37:00: (0) home/OMG_2nd_floor/SYStoMQTT {“uptime”:120,“freeMem”:30936,“rssi”:-47,“SSID”:“Level2”,“modules”:“Plight”}

However, If I enable ZgatewayRF as well, OMG stops publishing PilighttoMQTT messages, only this:

17:42:59: (0) home/OMG_2nd_floor/SYStoMQTT {“uptime”:120,“freeMem”:30232,“rssi”:-45,“SSID”:“Level2”,“modules”:“RFPilight”}

And there is no incoming signals in Serial Monitor, just ordinary “subscribed to all topics”.

I use RF_RECEIVER_PIN 0 in config_RF.h

Is it possible at all to receive both 433toMQTT and PilighttoMQTT messages?

It is not possible.
As ZgatewayPilight covers more protocol I advise you to go for it as the only one. But you have maybe some devices that doesnt work with ZgatewayPilight ?

I have ordinary 433MHz PIRs, door opening detectors and wall RF switches I currently control via OMG RF, but I hoped to add some DIGOO R8S sensors as well and be able to get their readings rather than use a separate RFLink gateway.
The trouble is if I enable only Pilight, I don’t get signals from any of my RF devices, hence my original question.

Interesting, could you give me links please to these different hardwares ?
With Pilight my plugs are working and also some other sensors. I should test them exhaustively to have a better understanding for everybody, on what each library does and does not.
What we haven’t tested yet is to put 2 receivers and to attach each gateway to one receiver. The code currently doesnt enable it.

Sonoff PIR2, Kerui 026 and GS-WDS07 door sensors…

I’m pretty sure there is something in OMG configuration I need to change for it to work as it’s strange that everything works when RF is enabled, but all RF goes away when Pilight is.

What do you mean? 2 OMGs, one with RF enabled and one with Plight?

I mean to put 2 receivers on one OMG board.

I will do some tests with this one.

Well, but what’s the point? It’s only about different protocols, right? And still the same OMG should do all that work of deciphering protocols… Or am I missing anything?

That would be great, thanks.

A gateway in OMG view is corresponding to one library (for one board) ; rcswitch, irremote, espilight…
Each library has its proper encoding/decoding methods.

This is the target, and by adding ZgatewayPilight we support more protocols , now we need to see how the protocols covered by ZgatewayRF could be all included in ZgatewayPilight

I can confirm that my gateway is able to receive open/close/tamper states of a Kerui D026 door sensors.
Have no idea what does “low battery” message look like though…

GS-WDS07 is definitely not detected…

I can confirm it to, The list of compatible devices has been updated when the device is not detected by Pilight or not yet tested.
Now I need to check how we can add the missing devices to Pilight…

yeah, that would be great to have Pilight instead of RF as they declare wide range of protocols etc, but so far many pretty standard 433MHz devices are not recognised… :frowning:

For the GS-WDS07 it was already done in a fork, I’ve made a PR so as to incorporate it in Pilight next release:

Please note that I have tested this fork on my local OMG and I confirm that GS WDS07 will work with this add

That’s great news indeed.
I get it you’ll need to release a new version when they update pilight library?
By the way, what it takes to add support for a new device?
I might do my bit and try to add Sonoff PIR2 support as I have one.

This should be the proper way, but if you don’t want to wait here is it

Doesn’t seems too hard if you take a look to the PR

Thanks a lot for your work!
I tried your code today and it works, hurray! Almost…

I can see codes coming from the DS07 sensor, but the mqtt message tags are slightly different compared to Kerui D026:

{“message”:{“unitcode”:441825,“state”:“closed”},“protocol”:“kerui_D026”,“length”:"",“repeats”:2,“status”:2}
{“message”:{“unit”:50555,“battery”:1,“state”:“closed”},“protocol”:“GS-iwds07”,“length”:"",“repeats”:2,“status”:2}

i.e it’s unitcode and unit for the code.
Shouldn’t it be standard?

I like that battery information is enclosed in every message for DS07, but do you know how to get battery status of Kerui D026?

It’ll take some time to get the idea, but to begin with I need to capture the RF signal, right?
Could you tell me how to get that raw data (i.e single that my device sends)?
I searched the forum, but have found noting apart from pilight-debug - the problem is I don’t know where to run it as I don’t know how to attach a receiver to my desktop…