Github Devices Community Docs Blog

GS-WDS07 433Mhz Door sensor with open/close status

Hi, i have a GS-WDS07 Sensor, can you help me with sensor for homeassistant, i receive the code for low battery but how i use it? thanks

hi,

a bit off topic maybe but…I have a couple of this sensor and using a gateway based on EspHome.

Usually to receive door sensors (I also have DIGOO switches) I set the receiver to rc_switch and dump the RF code (format is something like 10100101010) so binary one.

With these GS-WDS07 instead it seems I am not capturing anything: blue led is activating hence I guess it should be transmitting.
How are you doing to capture RF code?

I don’t quite get you.
Do you need help with receiving battery level or you don’t know how to use it in HA?
It would be useful if you could post a relevant bit of your sensor config here.

OMG sends all RF messages to a MQTT topic. Just subscribe to it an check what’s published when your sensor it tripped.

i have a 20 units GS-WDS07 , i wonder i i can convert it to water leak sensor ?
i have this water sensor
i try to soldering 2 wire to the reed but in my test its looks that the short not send the code.
mybe with tamper ? any idea ?

You should measure the impedance of the reed switch and try to replace it with a resistor with the same value first.
If working try to setup a circuit with your water sensor + the resistor or a lower one depending on the total impedance.

This sensor is a total of two pins that connect 2 wires and the water is supposed to shorten between them, I measured between the two REED legs and it gave 3.3V so that means it actually gives the trigger a trigger. The resistor you mean is actually going to simulate the resistance of the REED?
Because I shortened the sensor legs in a glass of water, it actually did nothing.
I am trying to understand the water sensor works whether it is really short or by lowering the resistance following the water.

Yes exactly

I think you should compare the impedance obtainer here with the reed switch one.

I measured the resistance on the REED and it gave me about 50 ohms.
The resistance on both connections after I removed the REED from the board is 1.5M ohms.
I put a 1.5M resistor between the two connections and connected the sensor but it did not help, if I put a resistor over 33K then no contact and still with the sensor is not a short sight to send the RF code.
I don’t really understand it, but I couldn’t really make the sensor a short character like the REED.
Do you have an idea or direction?

If you try to replace the REED with 50 ohms resistor or a close value do you succeed in triggering the sensor?

yes. i try many type of resistor values until 33Kohm . above 33K do nothing.
but with the resistor and the water sensor he do nothings

not 33K, 33ohms only and without the water sensor?

Yes I connected the resistor instead of the 33ohm resistor (I went up in values up to 33K) and it did give a trigger

any idea ?? :roll_eyes:

And the resistance of your water sensor when into the water is how much?

sorry cant remember now , i will check it and came back with the answer later

Also could you open a separate topic about this transformation?

ok… i will open new topic

@1technophile Something very interesting about this module is that it comes with a 1.5V AAA battery but if you put a AAA lithium battery it greatly increases its transmission range. It seems that all the modules I had problems with transmitting after replacing the battery started transmitting continuously and quickly…

Interesting, could you compare the voltage of the lithium one versus the provided one?

I did the measurements and here are the results:

AAA Battery : On Stand by is : 25uA , On transmission is : 27mA
AAA Lithium : On Stand by is : 12uA , On transmission is : 12mA

Lithium battery consumption seems to be really low in transmission compared to using a standard AAA battery.
In my opinion probably because lithium battery does not have to increase the voltage as with a normal battery (1.5V). I measure the voltage on REED connections with a normal battery I get 3.3V so there is probably wasted engry on the voltage conversion.
your opinion ?