Lilygo 433 rtl Error: Didn't get enough status bytes

I just picked up a few Lilygo 433mhz ESP32 boards to install the rtl package. I get the following error after the flash erase and the install reaches 100%, “Error: Didn’t get enough status bytes”. I am using a Mac (no windows PCs in the home) and Chrome; I could try a chromebook but not sure of the USB drivers. I execute the Web Upload option (image attached below). Any ideas on options on overcoming this? I have tried it multiple times and receive the same results each time. Thanks for any suggestions and I can provide any additional details needed if I’m missing something.

Hi @quella,

There have been reports of failed web uploads with macOS Big Sur and the Chrome browser, which didn’t happen when the same person uploaded on a Windows PC with the Edge browser.

While it is not clear if macOS Big Sur was the issue or Chrome on that particular Mac, it is definitely worth trying it on a Chromebook if you have the possibility.

I’ll give it a shot and see if the device is detected. I would do the ESP manual upload, but all the software from Espressif seems to be Windows only as well. I did see that one article recently posted but it did not have the exact error listed but if it is the same, I would suspect something with MacOS.

The most reliable really would be with Visual Studio Code and the Plarformio extension enabled within VSC - easy to install on macOS, epscially if you already have the driver installed. If you look up close at my avatar you’;ll see that I’m macOS based as well :wink:

I have VS Code and Platform IO installed on the same MAC. I will give it a go and see if I can do the manual install that way. Thanks for the good idea and testing. Thats what makes these things so much fun.

1 Like

Just install the Platformio extension in VSC, then download the OpenMQTTGatway source at the very bottom at

unzip it and open it with VSC.

One in there, I just do the push to the device and should be good to go. Let me go have a look at the download. Thanks for the link and assistance. Hopefully VSCode/Platform IO will solve the issue.

Looks like I’m going to have to take some time to read the " (Option 3) Upload your configurations" section well to make sure I have the correct Platformio.ini for the Lilygo esp32 along with the right configuration to ensure that build. Off to do some reading.

Alien head on the left side (Platformio) - PROJECT TASKS

Scoll down until you get to lilygo-rtl-433, expand it, Build, Upload

Ahh, that is the key. I just grabbed the specific Lilygo package. Let me look at the main source for OpenMQTT and select the option as you have shown. Thanks!

So I was able to build the package in PIO, but when I try to upload it I get a RAM error. I then issue in the PIO terminal “pio run --target erase” and all attempts fail when trying to erase the device. The device is direct from Lilygo and it is the 433mhz ESP32LORA module. I guess I will try to play some more with it or wait for some update to the project that may correct the issue. When I saw the YouTube from [Andreas Spiess] (Andreas Spiess - YouTube) he used the same TTGO 433mhz and was able to upload via the web. I can only assume it was a PC and Chrome he was using. I did try it via two different Mac systems all running MacOS Ventura. I may see if a Chromebook system works next. Thanks @DigiH for your earlier pointers. Off for more fun.

Andreas Spiess

Does your 433Mhz LilyGo LoRa32 have T3_V1.6.1 on the back? Or might it say something different?

Do you have the correct CH9102F driver for the LilyGo LoRa32 installed on macOS?

In that case you might just have to add the line

upload_port = /dev/cu.wchusbserial37F60476283

to the [env:lilygo-rtl_433] environment in environments.ini, and the options in PROJECT TASK should work.

I then issue in the PIO terminal “pio run --target erase” and all attempts fail when trying to erase the device

For the PIO terminal command to work you’d have to uncomment

;default_envs = lilygo-rtl_433

in platformio.ini, or also use the PROJECT TASK Erase Flash under the Platform sub section

Thanks again for the pointers and I will continue to work the issue on Mac systems. The simpler solution was to charge up the Chromebook system and that worked out of the box using the Web Upload and no errors. At least the device is up and operational so I can play more with it and Home Assistant.


@quella I had all types of problems with lilygo rtl433 failed upload rtl433 OMG on macOS BigSur and Chrome. New attempts failed and trying other ESP32 builds gave me other errors
Started to look at doing the VSCO PlatformIO route but looking at the expected workload I finally borrowed a win machine and bingo worked first try smooth as silk. Really suggest to locate or borrow a win machine for this as it is a real time saver

@LEMD49 thanks for the input and I would have gone to a family members home to use their Windows system had I not been able to get it working (100%) by using a Chromebook system I had here at the house. Surprised it worked with out any issues, simply plug and play. Now I am collecting all my Acurite weather systems in HA by way of this great project.

Just to clarify, as there have been a few reports with failed web uploads on macOS, but we cannot reproduce these in the team.

You both had the relevant drivers installed for the LilyGo boards, and selected these in the popup when the web upload gets initiated

With the driver download and installation explanation nicely described here

I do. The device appears as a USBSERIAL device when connected and or disconnected it goes away. The Web Upload also shows the right USB (along with two bluetooth devices) and when I click on them, the device is erased, etc. So, I have the proper drivers installed.

Does it show as just USBSERIAL or wchusbserial? As without the wch it might be a different USBtoSerial driver, which is only partially compatible, ok for erase but not for a full install.

Also with the linked to wchusbserial driver the version is crucial, especially with later macOS versions; the current version being v1.8 - supporting the LilyGo LoRa32 V2.1’s Serial Chip CH9102.

@DigiH I see my Mac connection to the Lilygo_433 on “/dev/cu.usbmodem56440207381”. Based on your note above, this would be using the wrong driver. I can try to install another system using the correct driver and give that a shot.

I see my Mac connection to the Lilygo_433 on “/dev/cu.usbmodem56440207381”. Based on your note above, this would be using the wrong driver.

Correct, this would definitely be the wrong driver. It really needs to show up as


@quella, that would be great, hopefully we can then get to the bottom of these stray macOS web upload issues and add a note on the page with a link to the correct driver for these boards, if the install resolves your previous problem. No need for a separate system though, as the driver can just be an additional driver installed on your current system.

Just to note, for a proper install finalisation don’t forget the confirmation in the Security section of System Preferences after the restart.