OMG on ESP8266 + CC1101 868MHz -- Newbie needs help

I’m trying to set up OMG on a ESP8266 (NodeMCU) with a CC1101 868MHz.

I have connected the CC1101 as follows: GD02 → GPIO4 and GD00 → GPIO5.
I have built an image with the following build_flags:

build_flags =

I’ve flashed the image and it’s running, I can see the MQTT messages in MQTTExplorer.

OMG/LWT online
OMG/version version_tag
OMG/SYStoMQTT {"uptime":1084,"version":"version_tag","freemem":34784,...,"actRec":2,"mhz":868.3,"modules":["RF","RF2"]}

But the rest is silence. No RF messages are recorded whatsoever (they are there — my other receiver is receiving them). I’m not even sure the CC1101 is functional or wired correctly, it doesn’t make a difference whether it is connected or not.

Any suggestions how to proceed?

Hi @sciurius,

I followed this for my 868MHz CC1101 connection

Is it the dedicated 868MHz CC1101, as seen on the bottom left of the above wiring chart?

Since you’re using


which sensor are you trying to register and decode with the setup, when you say your other receiver is receiving the messages fine? Could it be that you might need a different gateway definition for it?

1 Like

Hi @DigiH,

Yes, the board is the dedicated 868MHz CC1101.
I changed the emitter to GPIO13 (D7), no apparent changes.

The other receiver is a DVB SDR dongle that I use with the rtl_433 tool (on Linux) to receive the information from my Bresser 5-in-1 weather station.

Hi @sciurius,

I was suspecting something like that. Since you use the rtl_433 tool successfully for your Bresser weather station you would also need the rtl_433 library with OpenMQTTGateway. Have a look at the



But unfortunately also be aware of the rtl_433_ESP library currently not supporting FSK_PULSE_PCM modulation in the default release, which your Bresser 5-in-1 has, yet. I have the same problem with my 868MHZ FSK_PULSE_PCM modulation weather station.

There is a test branch to try, but whenever I test it to try and get some valuable information which I could get to @NorthernMan54 I am totally swamped by 50+ other 868MHz devices in my surroundings which make it virtually impossible to distinguish their encrypted non-decodable messages from a possible weather station signal for examination.

Maybe you also want to try the rtl_433_ESP fsk test branch, where your "Bresser Weather Center 5-in-1" is listed under FSK Devices Supported

Hope this makes it clearer :wink:

Hi @DigiH,

Yes, this makes things clearer… Unfortunately the rtl_433 library needs ESP32 and I only have a pile of ESP8266s…

OTOH, even though the Bresser protocol is not understood, I’ expect to see raw data messages.

That’s a good question, but only with the two


defined I’m actually not sure.

Hopefully someone else can chip in to answer this.

I hope so. Right now I do not have the faintest idea whether the CC1101 is functional.

How about setting the frequency to 433MHZ, just to see if some usually more ubiquitous (RF and RF2) 433MHz device are in your vicinity. Of which you might even have some yourself.

While from my experience the range of a 868 CC1101 set to 433MHZ CC1101, and vice versa, isn’t nearly as good as a proper 433MHZ CC11101 it should still work to pick up something.

That would be just guesswork…
I have an 868.30 remote control next to the CC1101 so I think it should pick up something.

It really bugs me that apparently there is no way that OMG can check a device.

Just to clarify, you are talking about seeing nothing when monitoring with a serial connection, not just in the MQTT messages, right?

The only thing I have is the MQTT messages.
How can I monitor serial (the NodeMCU is connected via USB to the PC)?

There won’t be any MQTT messages with any raw data for undecoded devices, thankfully I find, as otherwise the MQTT broker would/could be flooded with such unwanted messages :wink:

The only way I have experience with is with plaformio which I personally use for all OMG custom builds and serial monitoring with a ESP32 or ESP8266 connected to my PC.

What did you use for your build?

Apparently others also know of other ways using prebuilt binaries and nodemcu flasher, as stated here

Yes, I also use platformio. So I can do “pio device monitor” and I get messages that correspond to the MQTT messages. I cannot type anything, it doesn’t respond to Ctrl+T.

Do I need to add debug flags to the build?

Do you also use Visual Studio Code with platformio? And in the environment section under the patformio tab

and chose Monitor or Upload and Monitor you don’t see any output in the bottom TERMINAL window? Starting with something like

************* WELCOME TO OpenMQTTGateway **************
N: OpenMQTTGateway Version: 0.9.13
N: WiFi ok with manual config credentials

I would assume for just monitoring and seeing if something might be received, even if not decoded you should be fine with the default settings, but for finer detail try :wink:


Not sure about any RF specific debug setting at the moment.

Also which upload_port have you got defined? Possibly also a separate monitor_port with same port required for your setup?

No … to the right of the PLATFORMIO QUICK ACCESS where you can chose to have both


There we are :slight_smile:

Have you tried specifying a monitor_port underneath board_build.flash_mode = dout?

Would that help? The port changes depending on the USB devices being plugged in/out.

In the terminal window I get messages, so it is definitely connected to the devidce:

If you want we can take this to Telegram?

EDIT: Ran out of allowed replies. Must wait 17 hours. Stupid.