Github Boards Devices Community Docs Blog

SonOff RF Bridge v2 broken after OMG firmware

Hi team, I have one SonOff RF Bridge R2 working with ESPurna firmware. Hardware NOT MODIFIED.
I made and upgrade loading latest RFBRIDGE_OpenMQTTGateway_V092.bin firmware from OMG with my tasmotize software and mi FTDI connected at GND/RX/TX/3V3 pins on the board.

  1. Unplug the board
    2.Plug the FTDI pins
    3.Move the board switch to OFF
    4.Press and hold the reset button (pairing button)
    5.Power the board via FTDI
    6.Wait for 5 sec and release the reset button
    7.Starts TASMOTIZE and flash the board

Flashing OK and, then, power off FTDI, unplug it, move the switch to ON and plug the board to USB power.

Only the SonOff Logo LED lights…nothing happens…no SSID, no Wifi LED…

I tried to reflash it again with ESPurna, OMG, original firmware…but it was impossible!!! The board doesn’t responds!!! TASMOTIZE software says that there is NO Serial connectivity to the board.

I tried with another flashing software and another FTDI device…nothing works.

I seems that, after OMG flashing, the device is out of service…and I can’t recover it !!!

Hi,

Could you try to erase the flash memory ?

I have never tested this combination so I’m not sure if it works with OMG …

Hi Florian,

Tasmotize is only an app to flash. We try with NodeMCU PyFlasher…

but it doesn’t connect to the board

Hi,

Do you see the FTDI led blinking when it try to connect to the board?

I tried it with platformIO…

same error, can’t connect to the board .

It seams that the board ESP is KO after OMG

yes, the FTDI led blinks red for a 3-4 seconds and stops, blink 3-4 seconds and stop…
This FTDI works fine with another board ( SonOff POW-R2) I tried with this POW right now and all its Ok.
I have some other FTDI boards…I tried with 3 different FTDI that works with another board…

I’m really sure that my FTDI works fine. The RF Bridge was working fine before de OMG flash. I can flash it with OMG without issue, but when I rebooted the board…the board was dead!!

When you flashed it first time, did you erased the flash?

I’m not sure, but probably yes because it is my default behavior when I flash new firmware on a board. When I made an update I didn’t erase flash, but when I’m installing new/different firmware I check the erase flash option.

I’m not worried about KO board (it is only 12 € board and I have two working RF Bridge with ESPurna Direct bridge firmware.

But I’m interested in your approx to MQTT gateway because it is more effective than Dummy switches in RF Bridge… I don’t wanna try it again with another RF!!!

I have this example of successful update from Tasmota to OpenMQTTGateway but not from ESPurna.

One last thing maybe, could you connect GPIO0 to ground when connecting and flashing?

I can try it. Where is the GPIO-0 on the board?

Before trying it you may verify that it is not already at ground.

I can try it. Where is the GPIO-0 on the board?


p9

I don’t understand anything!!! I reboot the board and I have blue WiFi led permanent ON…It doesn’t matter if I power on with button hold, switch ON/OFF…the Blue LED stays ON…

GPIO-0 to ground not required, just updated to v094 2 days ago and all is good.
Ensure you disconnect RX/TX after the upgrade if you use the FTDI to power the Sonoff.
Isn’t the hardware hack required to load OMG? it is if you want to use Pilight…
I can confirm without a doubt that it does work, Platform IO can be tricky but let me know if you get there and encounter issues.
Cheers,

Hi, I put the GPIO0 to ground. Nothing changes…I can’t connect to the board via UART